Toybrick

标题: 转RK模型 Network may not support batch>1 ! [打印本页]

作者: mrzs    时间: 2020-2-5 20:19
标题: 转RK模型 Network may not support batch>1 !
本帖最后由 mrzs 于 2020-2-5 20:42 编辑

--> Loading model
W Network may not support batch > 1 !
W Network may not support batch > 1 !
W Network may not support batch > 1 !
W Network may not support batch > 1 !
W Network may not support batch > 1 !
W Network may not support batch > 1 !
W Network may not support batch > 1 !
W Network may not support batch > 1 !
W Network may not support batch > 1 !
W Network may not support batch > 1 !
W Network may not support batch > 1 !
W Network may not support batch > 1 !
done
--> Building model
done
请问 这种 warning 怎么消除
是否影响模型运行

作者: mrzs    时间: 2020-2-6 08:32
搞了个板子跑了一下,报的错误是 invalid model ...     请教一下各位大佬,转模型出现这种warning是咋回事啊
作者: jefferyzhang    时间: 2020-2-7 13:01
按NPU部门同事解释,这个warning不影响使用。
你只要确认你转换之前的模型是freeze的就可以。

invalid model是因为你drv和api版本不匹配造成的,请统一升级到1.3.0再试
作者: tshan    时间: 2020-2-7 13:13
jefferyzhang 发表于 2020-2-7 13:01
按NPU部门同事解释,这个warning不影响使用。
你只要确认你转换之前的模型是freeze的就可以。

drv如何升到最新,用的新版本的debian和fedro,update之后Drv仍然是0.9.9
作者: jefferyzhang    时间: 2020-2-7 15:59
tshan 发表于 2020-2-7 13:13
drv如何升到最新,用的新版本的debian和fedro,update之后Drv仍然是0.9.9

用debian10,然后apt update和pip install --update即可
作者: tshan    时间: 2020-2-9 11:01
jefferyzhang 发表于 2020-2-7 15:59
用debian10,然后apt update和pip install --update即可

dvr更新到1.3.0了。
新问题:
1. debian上apt upgrade toolkit-rk3399pro更新toolkit版本是1.2.1;
2. pc上模拟跑出来的结果和3399pro上跑出来的结果不同
作者: jefferyzhang    时间: 2020-2-9 14:06
tshan 发表于 2020-2-9 11:01
dvr更新到1.3.0了。
新问题:
1. debian上apt upgrade toolkit-rk3399pro更新toolkit版本是1.2.1;

toolkit也是1.3.0,用pip3的 update




欢迎光临 Toybrick (http://t.rock-chips.com/) Powered by Discuz! X3.3