Toybrick

标题: rknn_api最新版本链接失效 [打印本页]

作者: Pony    时间: 2020-9-14 18:35
标题: rknn_api最新版本链接失效
如题,论坛里给的1.3.3版本的github链接失效,而且rknn_api的文档也只到1.3.0,能否给出最新版本的链接以及安装说明

作者: jefferyzhang    时间: 2020-9-14 22:27
由于法律原因,代码和发布的包都在进行内部审查中,审查完毕即会发布,请稍等两天
作者: Godspeed    时间: 2020-10-9 11:04
想问一下 1.3.3 版本的API 适用于toolkit 1.40 转换的模型吗?
作者: jefferyzhang    时间: 2020-10-9 12:00
Godspeed 发表于 2020-10-9 11:04
想问一下 1.3.3 版本的API 适用于toolkit 1.40 转换的模型吗?

最好要匹配,不匹配可能运行很正常,也可能会有未知错误。
作者: Godspeed    时间: 2020-10-9 13:06
jefferyzhang 发表于 2020-10-9 12:00
最好要匹配,不匹配可能运行很正常,也可能会有未知错误。

好的,现在由于onnx对上采样操作的支持问题只能使用1.4.0版本的toolkit,只能一边实验其他版本API一边等待1.4.0 版本API发布啦
作者: zjleung    时间: 2020-10-9 13:44
jefferyzhang 发表于 2020-9-14 22:27
由于法律原因,代码和发布的包都在进行内部审查中,审查完毕即会发布,请稍等两天 ...

我在PC上用最新发布的RKNN-TOOLKIT1.4.0成功将模型转换,并且调通整个过程,模型输出的结果是4维的。可是真正将代码拷贝到计算棒上运行时,得到的输出是2维的,而且试过各个reshape的形状都不是在PC输出的结果。我怀疑是不是计算棒上的rknn-api不是最新的。
#问题一:如何查看自己计算棒上的rknn-api的版本,在网页上看只能看到RKNN-Version=1.4.0?
#问题二:如果是在计算棒上确实需要reshape的,那是(n,c,h,w)还是(n,h,w,c),我的rknn模型的输入设置的是(n,c,h,w)。
作者: jefferyzhang    时间: 2020-10-9 14:30
Godspeed 发表于 2020-10-9 13:06
好的,现在由于onnx对上采样操作的支持问题只能使用1.4.0版本的toolkit,只能一边实验其他版本API一边等 ...

我们正在上传1.4.0,等晚上再来看下,应该传好了




欢迎光临 Toybrick (http://t.rock-chips.com/) Powered by Discuz! X3.3