Toybrick

Pytorch现在支持吗

运河边边上

注册会员

积分
75
发表于 2020-3-14 18:32:09    查看: 200|回复: 10 | [复制链接]    打印 | 显示全部楼层
pytorch用的比较多,装了半天还是装不上。。。之前看帖子说还没支持。。
回复

使用道具 举报

jefferyzhang

超级版主

积分
3675
发表于 2020-3-15 10:24:33 | 显示全部楼层
rknn 1.3  支持 pytorch1.2 版本
回复

使用道具 举报

运河边边上

注册会员

积分
75
 楼主| 发表于 2020-3-16 09:39:19 | 显示全部楼层
jefferyzhang 发表于 2020-3-15 10:24
rknn 1.3  支持 pytorch1.2 版本

大佬  我的意思是 :板子上python能装pytorch? import torch 使用吗
回复

使用道具 举报

jefferyzhang

超级版主

积分
3675
发表于 2020-3-16 09:41:50 | 显示全部楼层
运河边边上 发表于 2020-3-16 09:39
大佬  我的意思是 :板子上python能装pytorch? import torch 使用吗

当然可以,我们板子也是通用架构+发行版Linux,能装都能跑。
只是跑的CPU而已
回复

使用道具 举报

运河边边上

注册会员

积分
75
 楼主| 发表于 2020-3-16 09:43:00 | 显示全部楼层
jefferyzhang 发表于 2020-3-16 09:41
当然可以,我们板子也是通用架构+发行版Linux,能装都能跑。
只是跑的CPU而已 ...

好得
回复

使用道具 举报

zengwubin

注册会员

积分
71
发表于 2020-3-21 18:34:28 | 显示全部楼层
请问你是怎么安装torch的, 我安装了一个运行是报错ImportError: libcudart.so.10.0: cannot open shared object file: No such file or directory,  知道怎么解决吗?
回复

使用道具 举报

运河边边上

注册会员

积分
75
 楼主| 发表于 2020-3-26 14:40:04 | 显示全部楼层
zengwubin 发表于 2020-3-21 18:34
请问你是怎么安装torch的, 我安装了一个运行是报错ImportError: libcudart.so.10.0: cannot open shared o ...

我还没装成功呢
回复

使用道具 举报

rlgl

注册会员

积分
68
发表于 6 天前 | 显示全部楼层
jefferyzhang 发表于 2020-3-16 09:41
当然可以,我们板子也是通用架构+发行版Linux,能装都能跑。
只是跑的CPU而已 ...

请问板子上(rk3399proD)是怎么装pytorch的,pytorch官方好像没发布arm端的安装包,我使用的命令是
pip install torch==1.2.0+cpu torchvision==0.4.0+cpu -f https://download.pytorch.org/whl/torch_stable.html --user
提示错误:No matching distribution found for torch==1.2.0+cpu。
我现在板子上rknn_toolkit_1.3.0已经配置好了,./example/tflite中的示例也可以成功运行,但./example/pytorch中的示例无法运行,pytorch和torchvision都安装不上,求大佬解答下,被这问题折磨一周了已经,尝试了很多方法,试过的方法写在这个帖子里,目前还没人回应http://t.rock-chips.com/forum.ph ... tid=1420&extra=
回复

使用道具 举报

jefferyzhang

超级版主

积分
3675
发表于 6 天前 | 显示全部楼层
rlgl 发表于 2020-3-31 11:04
请问板子上(rk3399proD)是怎么装pytorch的,pytorch官方好像没发布arm端的安装包,我使用的命令是
pip  ...

我们是芯片公司。。。不会去干预debian10的包管理和社区维护内容。。
这种东西你们可以去google pytorch1.2有没有arm版本的来安装,没有的话就在pc上搞就可以了。
不过既然你们提出来了,我们回头有空可以去收集下arm版pytorch
回复

使用道具 举报

rlgl

注册会员

积分
68
发表于 6 天前 | 显示全部楼层
jefferyzhang 发表于 2020-3-31 11:16
我们是芯片公司。。。不会去干预debian10的包管理和社区维护内容。。
这种东西你们可以去google pytorch1 ...

谢谢您的回复,我再问个问题
我的目的是:将pytorch模型转为rknn模型,然后在rk3399prod开发板上进行推理
您提到可以在pc上搞,我理解的意思是不是这样做
1. pc上配置rknn_toolkit_v1.3.0+pytorch1.2.0,然后在pc上将pytorch模型转为rknn模型,此时仅仅需要pc就可,不需要将开发板连接到pc;
2. 开发板配置好rknn_toolkit_v1.3.0环境,将转换后的rknn模型拷贝到开发版上进行推理。

目前我正在pc端尝试配置rknn_toolkit_v1.3.0+pytorch1.2.0,win10和ubuntu16.04上都在尝试,参考“Rockchip_User_Guide_RKNN_Toolkit_V1.3.0_CN.pdf”、“Rockchip_Quick_Start_RKNN_Toolkit_V1.3.0_CN.pdf”这两个文档去安装,最让我不解的是按照Rockchip_User_Guide_RKNN_Toolkit_V1.3.0_CN.pdf文档中的3.1.2节:“通过dock进行安装”,也无法成功,提示illegal instruction(core dumped)失败截图我上传到这个帖子了http://t.rock-chips.com/forum.ph ... tid=1420&extra=
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表