Toybrick

MPP解码失败

MadDog

注册会员

积分
50
发表于 2020-12-31 10:47:56    查看: 295|回复: 13 | [复制链接]    打印 | 显示全部楼层



请问这是什么原因?有什么办法解决吗?板子名称是:TB-RK3399ProDs, 型号是 T331040232D,刷了最新的系统,在debian用
自带的解码程序进行硬解码测试

谢谢!

回复

使用道具 举报

MadDog

注册会员

积分
50
 楼主| 发表于 2020-12-31 10:48:44 | 显示全部楼层
mpp_device: mpp_device_send_reg ioctl VPU_IOC_SET_REG failed ret -1 errno 14 Bad address
mpp_device: mpp_device_wait_reg ioctl VPU_IOC_GET_REG failed ret -1 errno 110 Connection timed out
回复

使用道具 举报

jefferyzhang

超级版主

积分
7030
发表于 2020-12-31 15:19:34 | 显示全部楼层
不知道你在说什么。解码什么失败,不考虑下src有问题直接就认为mpp有问题?
回复

使用道具 举报

MadDog

注册会员

积分
50
 楼主| 发表于 2021-1-5 16:46:05 | 显示全部楼层
jefferyzhang 发表于 2020-12-31 15:19
不知道你在说什么。解码什么失败,不考虑下src有问题直接就认为mpp有问题? ...

我是运行mpi_dec_test程序,解码一个H264文件,mpi_dec_test是源码编译的,H264文件用ffmpeg播放都没有问题,运行的结果在附件的图中。
请问这是我mpi_dec_test编译的问题,还是H264文件的问题呢?
谢谢

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

jefferyzhang

超级版主

积分
7030
发表于 2021-1-5 16:56:15 | 显示全部楼层
板子自带的mpi_dec_test为什么不试试,为什么要自己编译mpp?
回复

使用道具 举报

MadDog

注册会员

积分
50
 楼主| 发表于 2021-1-7 14:59:05 | 显示全部楼层
板子刚到的时候就试过,预置的是fedora系统,mpi_dec_test测试有问题,所以就重装了系统看看能否解决问题,但是重装后仍然有问题。编码解码的都报错
回复

使用道具 举报

jefferyzhang

超级版主

积分
7030
发表于 2021-1-7 15:02:32 | 显示全部楼层
MadDog 发表于 2021-1-7 14:59
板子刚到的时候就试过,预置的是fedora系统,mpi_dec_test测试有问题,所以就重装了系统看看能否解决问题, ...

你烧的是最新的v1.8的debian10么?把你264文件+命令发上来,我们试试
回复

使用道具 举报

MadDog

注册会员

积分
50
 楼主| 发表于 2021-1-8 09:27:52 | 显示全部楼层
系统是最新版本的:

命令为:./mpi_dec_test -i test.h264 -t 7 -n 10h264文件用了很多个,各种方式生成的,没有一个可以解码成功的,但是ffmpeg全部都能解码成功。解码报错信息如下:


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

MadDog

注册会员

积分
50
 楼主| 发表于 2021-1-8 09:33:40 | 显示全部楼层
系统版本及报错截图详见附件







本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

MadDog

注册会员

积分
50
 楼主| 发表于 2021-1-12 09:29:26 | 显示全部楼层
@jefferyzhang

请问这个问题你那边会出现吗?
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表