Toybrick

[RKNN] Can not find libdrm.so

mogududu

注册会员

积分
58
发表于 2021-7-23 19:34:53    查看: 2927|回复: 7 | [复制链接]    打印 | 显示全部楼层
[RKNN] Can not find libdrm.so 出现这个错误的原因是什么呢?
回复

使用道具 举报

jefferyzhang

论坛元老

积分
10090
发表于 2021-7-24 23:56:45 | 显示全部楼层
sudo apt install libdrm
回复

使用道具 举报

mocas_wang

注册会员

积分
62
发表于 2021-10-9 19:55:52 | 显示全部楼层

不行,找不到这个信息。Unable to locate package libdrm
回复

使用道具 举报

LS1030

新手上路

积分
35
发表于 2022-1-10 11:42:46 | 显示全部楼层
mocas_wang 发表于 2021-10-9 19:55
不行,找不到这个信息。Unable to locate package libdrm

请问一下这个问题解决了吗?

我用locate libdrm.so找到了以下两个:
/usr/lib/aarch64-linux-gnu/libdrm.so.2
/usr/lib/aarch64-linux-gnu/libdrm.so.2.4.0,
新建一个libdrm.so软连接到libdrm.so.2.4.0,不知道可不可以?
回复

使用道具 举报

一只浩浩浩文呐

注册会员

积分
67
发表于 2022-1-20 14:47:57 | 显示全部楼层

你好 找不到libdrm呀 请问这个问题怎么解决呢
以及 根据https://t.rock-chips.com/forum.p ... &extra=page%3D1这个教程出现的找不到设备是因为这个包引起的嘛?
回复

使用道具 举报

jefferyzhang

论坛元老

积分
10090
发表于 2022-1-20 17:44:54 | 显示全部楼层
一只浩浩浩文呐 发表于 2022-1-20 14:47
你好 找不到libdrm呀 请问这个问题怎么解决呢
以及 根据https://t.rock-chips.com/forum.php?mod=viewth ...

只要是toybrick板子,apt install libdrm或者叫 apt install libdrm2 都有
回复

使用道具 举报

一只浩浩浩文呐

注册会员

积分
67
发表于 2022-1-20 18:59:24 | 显示全部楼层
jefferyzhang 发表于 2022-1-20 17:44
只要是toybrick板子,apt install libdrm或者叫 apt install libdrm2 都有

是toybrick的板子 TB-RV1126D_V11
然后 libdrm 找不到 libdrm2显示已经是最新的
root@debian10:/home/toybrick# apt install libdrm2
Reading package lists... Done
Building dependency tree      
Reading state information... Done
libdrm2 is already the newest version (2.4.97-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@debian10:/home/toybrick# apt install libdrm
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E: Unable to locate package libdrm


我重新运行了demo 通了 但是还是显示缺少那个libdrm  这个有影响吗?

--> Init runtime environment
[RKNN] Can not find libdrm.so
librknn_runtime version 1.7.0 (0bef7b3 build: 2021-08-18 19:55:01 base: 1131)
done
--> get sdk version:
==============================================
RKNN VERSION:
  API: librknn_runtime version 1.7.0 (0bef7b3 build: 2021-08-18 19:55:01 base: 1131)
  DRV: 6.4.6.5.351518
==============================================

done
--> Running model
resnet18
-----TOP 5-----
[812]: 0.9993900656700134
[404]: 0.0004593880439642817
[657 833]: 2.9284517950145528e-05
[657 833]: 2.9284517950145528e-05
[895]: 1.850890475907363e-05

done
回复

使用道具 举报

jefferyzhang

论坛元老

积分
10090
发表于 2022-1-21 08:36:10 | 显示全部楼层
一只浩浩浩文呐 发表于 2022-1-20 18:59
是toybrick的板子 TB-RV1126D_V11
然后 libdrm 找不到 libdrm2显示已经是最新的
root@debian10:/home/toy ...

应该没影响,你可以试试软连接一个libdrm.so到 /usr/lib目录下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表