Toybrick

运行rknn_toolkit中的example时候报错

sunxing

注册会员

积分
60
发表于 2019-5-5 19:35:10    查看: 7336|回复: 2 | [复制链接]    打印 | 显示全部楼层
(rknn) root@d5b771b0883d:~/rknn-toolkit/rknn-toolkit/example/mobilenet-ssd# python3 ssd.py
--> Loading model
done
--> Building model
E Catch exception when building RKNN model!
T Traceback (most recent call last):
T   File "rknn/api/rknn_base.py", line 459, in rknn.api.rknn_base.RKNNBase.build
T   File "rknn/api/rknn_base.py", line 952, in rknn.api.rknn_base.RKNNBase._quantize
T   File "rknn/base/RKNNlib/app/tensorzone/workspace.py", line 231, in rknn.base.RKNNlib.app.tensorzone.workspace.Workspace.load_data
T   File "rknn/base/RKNNlib/app/tensorzone/graph.py", line 32, in rknn.base.RKNNlib.app.tensorzone.graph.Graph.load_data
T   File "rknn/base/RKNNlib/RKNNnet.py", line 379, in rknn.base.RKNNlib.RKNNnet.RKNNNet.load_data
T   File "rknn/base/RKNNlib/RKNNnet.py", line 391, in rknn.base.RKNNlib.RKNNnet.RKNNNet._load_old_data
T   File "rknn/base/RKNNlib/RKNNnet.py", line 392, in rknn.base.RKNNlib.RKNNnet.RKNNNet._load_old_data
T   File "/root/rknn-toolkit/rknn-toolkit/rknn/lib/python3.6/site-packages/numpy/lib/npyio.py", line 447, in load
T     pickle_kwargs=pickle_kwargs)
T   File "/root/rknn-toolkit/rknn-toolkit/rknn/lib/python3.6/site-packages/numpy/lib/format.py", line 692, in read_array
T     raise ValueError("Object arrays cannot be loaded when "
T ValueError: Object arrays cannot be loaded when allow_pickle=False
done
E RKNN model data is None, please load model first!
--> Init runtime environment
done
--> Running model
E RKNN model is None, please load model first!
done
inference result:  None
Traceback (most recent call last):
  File "ssd.py", line 88, in <module>
    predictions = outputs[1].reshape((1, NUM_RESULTS, 4))
TypeError: 'NoneType' object is not subscriptable

我直接在PC上跑
有人遇到这个问题吗?

说明:
1、我是在docker中,安装了cuda以及cudnn
2、系统:
(rknn) root@d5b771b0883d:~/rknn-toolkit/rknn-toolkit/example/mobilenet-ssd# uname -a
Linux d5b771b0883d 4.18.0-18-generic #19~18.04.1-Ubuntu SMP Fri Apr 5 10:22:13 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

努力吧,少年。。。
回复

使用道具 举报

sunxing

注册会员

积分
60
 楼主| 发表于 2019-5-5 19:40:33 | 显示全部楼层
补充下,库的版本如下
(rknn) root@d5b771b0883d:~/rknn-toolkit/rknn-toolkit/example/mobilenet-ssd# pip list
Package              Version
-------------------- --------
absl-py              0.7.1
astor                0.7.1
Click                7.0
decorator            4.4.0
dill                 0.2.8.2
Flask                1.0.2
flatbuffers          1.9
gast                 0.2.2
grpcio               1.20.1
h5py                 2.9.0
itsdangerous         1.1.0
Jinja2               2.10.1
Keras-Applications   1.0.7
Keras-Preprocessing  1.0.9
lmdb                 0.94
Markdown             3.1
MarkupSafe           1.1.1
mock                 3.0.4
networkx             1.11
numpy                1.16.3
onnx                 1.5.0
opencv-python        4.1.0.25
Pillow               6.0.0
pip                  19.1
pkg-resources        0.0.0
protobuf             3.7.1
rknn-toolkit         0.9.9
ruamel.yaml          0.15.82
scipy                1.2.1
setuptools           41.0.1
six                  1.12.0
tensorboard          1.13.1
tensorflow-estimator 1.13.0
tensorflow-gpu       1.13.1
termcolor            1.1.0
typing               3.6.6
typing-extensions    3.7.2
Werkzeug             0.15.2
wheel                0.33.1
努力吧,少年。。。
回复

使用道具 举报

sunxing

注册会员

积分
60
 楼主| 发表于 2019-5-5 20:00:56 | 显示全部楼层
好吧,我解决了,我把numpy的版本降低到1.16.1后可以了,安装文档上说的是 >=1.16.1,看来是有问题的
努力吧,少年。。。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表