Toybrick

安装MMP和gstreamer-rockchip后不能正常运行

BlackBoy_Xuan

注册会员

积分
108
发表于 2019-5-14 19:01:21    查看: 10135|回复: 3 | [复制链接]    打印 | 显示全部楼层
如图所示,已经安装好MMP库和gstreamer-rockchip插件,本来想执行
#sudo gst-launch-1.0 v4l2src device=/dev/video0 ! "image/jpeg,width=1280,height=720,framerate=30/1" ! jpegdec ! videoconvert ! queue ! mpph264enc ! queue ! h264parse ! flvmux streamable=true ! queue ! rtmpsink sync=false location='rtmp://10.50.1.202:1935/live/test'
推流,但出现问题。然后缩小gstreamer launch,简化为
#sudo gst-launch-1.0 v4l2src device=/dev/video0 ! "image/jpeg,width=1280,height=720,framerate=30/1" ! jpegdec ! videoconvert ! queue ! mpph264enc ! appsink
仍出现问题,有人遇到过类似的问题吗?

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

BlackBoy_Xuan

注册会员

积分
108
 楼主| 发表于 2019-5-15 11:21:45 | 显示全部楼层
此外,执行mpi_test时,出现如下报错:
[toybrick@localhost ~]$ mpi_test
mpi_test: mpi_test start
mpi_test: mpi_test decoder test start
mpi: mpp_create enter ctx 0x7fc3520d60 mpi 0x7fc3520d58
mpi: mpp version: Without VCS info
mpi: mpp_create leave ret 0 ctx 0x1ad20fc0 mpi 0x7f902586f8
mpi: mpp_init enter ctx 0x1ad20fc0 type 0 coding 0
mpp: unable to create unsupported type 0 coding 0
mpi: mpp_init leave ret -1
mpi_test: mpp_init failed
mpi: mpp_destroy enter ctx 0x1ad20fc0
mpi: mpp_destroy leave ret 0
mpi_test: mpi_test failed


是不是还需要安装其他库呢?
回复

使用道具 举报

mahongwei

注册会员

积分
147
发表于 2019-7-26 21:48:44 | 显示全部楼层
我也遇到了一样的问题
回复

使用道具 举报

sauron

新手上路

积分
21
发表于 2019-9-19 14:37:12 | 显示全部楼层
BlackBoy_Xuan 发表于 2019-5-15 11:21
此外,执行mpi_test时,出现如下报错:
[toybrick@localhost ~]$ mpi_test
mpi_test: mpi_test start

请问解决了么,我这边也遇到了这个问题。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表