Toybrick

Tensorflow模型转换时,加载模型失败

mangmang359

新手上路

积分
45
发表于 2020-2-14 11:17:09    查看: 411|回复: 3 | [复制链接]    打印 | 显示全部楼层
环境:ubuntu 18.04
RKNN-Tool版本:1.2.1 (1.3版本由于网络原因无法下载)
模型:tensorflow
转换代码如下:
from rknn.api import RKNN
INPUT_SIZE = 512
if __name__ == '__main__':  
    rknn = RKNN()
    rknn.config(channel_mean_value='0 0 0 255', reorder_channel='2 1 0')
    print('--> Loading tensorflow model')
    rknn.load_tensorflow(tf_pb='./mobilebet.pb',
                         inputs=['input_1'],
                         outputs=['dense_2/Sigmoid'],
                         input_size_list=[[INPUT_SIZE, INPUT_SIZE, 3]])
    print('done')
    print('--> Building rknn model')
    rknn.build(do_quantization=False)
    print('done')
    rknn.export_rknn('./Mob2.rknn')
    rknn.release()


报错信息如下:
Instructions for updating:
Use tf.compat.v1.graph_util.extract_sub_graph
E Catch exception when loading tensorflow model: ./mobilebet.pb!
E Traceback (most recent call last):
E   File "rknn/api/rknn_base.py", line 190, in rknn.api.rknn_base.RKNNBase.load_tensorflow
E   File "rknn/base/RKNNlib/converter/convert_tf.py", line 639, in rknn.base.RKNNlib.converter.convert_tf.convert_tf.match_paragraph_and_param
E   File "rknn/base/RKNNlib/layer/customlayer.py", line 72, in rknn.base.RKNNlib.layer.customlayer.CustomLayer.load_params_from_tf
E TypeError: load_params_from_tf() takes at least 5 positional arguments (3 given)
done
--> Building rknn model
Traceback (most recent call last):
  File "convert_rknn_tensorflow.py", line 28, in <module>
    rknn.build(do_quantization=False)
  File "/usr/local/lib/python3.6/dist-packages/rknn/api/rknn.py", line 148, in build
    inputs = self.rknn_base.net.get_input_layers()
AttributeError: 'NoneType' object has no attribute 'get_input_layers'

回复

使用道具 举报

jefferyzhang

超级版主

积分
5121
发表于 2020-2-14 16:55:25 | 显示全部楼层
1. tensorflow版本多少?
2. 请把rknntoolkit升级到1.3.0
回复

使用道具 举报

mangmang359

新手上路

积分
45
 楼主| 发表于 2020-2-14 17:00:57 | 显示全部楼层
jefferyzhang 发表于 2020-2-14 16:55
1. tensorflow版本多少?
2. 请把rknntoolkit升级到1.3.0

tensorflow 1.13.1
rknntoolkit 1.3.0 由于网络原因下载不下来
回复

使用道具 举报

jefferyzhang

超级版主

积分
5121
发表于 2020-2-14 17:12:07 | 显示全部楼层
mangmang359 发表于 2020-2-14 17:00
tensorflow 1.13.1
rknntoolkit 1.3.0 由于网络原因下载不下来

1. 你必须用1.3.0来报bug,不然我们那边负责NPU的部门是不会接受老版本bug上报的。
2. 这个我自己有遇到过一次类似的是因为python环境问题造成的,后来全部重装了下环境就好了,莫名其妙的。不确定你遇到的跟我是不是一样的。
3. 你的input节点可以往挪下一个,放到第一个layer上去试试
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表