Toybrick

RK3399PRO开发环境

润城

注册会员

积分
127
发表于 2020-9-4 11:56:15    查看: 753|回复: 7 | [复制链接]    打印 | 显示全部楼层
各位好:
     咨询请教一下各位大神、大佬、大侠一下问题:
     1、用RK3399PRO开发板目前支持Linux哪个版本,目前支持最好linux版本?
     2、在PC上运行各种工具包,都支持哪个Linux版本,支持最好的版本是哪个?
     感谢!


回复

使用道具 举报

jefferyzhang

超级版主

积分
7596
发表于 2020-9-4 12:03:02 | 显示全部楼层
Toybrick板子建议刷官方Debian10固件,才能用我们的OTA在线升级rknn功能。
pc随意,要编译安卓按google要求最好是ubuntu
回复

使用道具 举报

润城

注册会员

积分
127
 楼主| 发表于 2020-9-4 15:40:46 | 显示全部楼层
jefferyzhang 发表于 2020-9-4 12:03
Toybrick板子建议刷官方Debian10固件,才能用我们的OTA在线升级rknn功能。
pc随意,要编译安卓按google要求 ...

我的板子是Toybrick TB-RK3399ProD,如果在PC上用RKNN-Toolkit生成软件可以在板端运行的模型文件(例如YOLOV3),这PC上也是安装Ubuntu16.04或18.04吗?感谢!
回复

使用道具 举报

jefferyzhang

超级版主

积分
7596
发表于 2020-9-4 16:04:53 | 显示全部楼层
润城 发表于 2020-9-4 15:40
我的板子是Toybrick TB-RK3399ProD,如果在PC上用RKNN-Toolkit生成软件可以在板端运行的模型文件(例如YO ...

不需要,Linux都是一样的。。
PC上rknntoolkit跑的是仿真程序,板子上才是用NPU跑的
回复

使用道具 举报

润城

注册会员

积分
127
 楼主| 发表于 2020-9-4 16:11:22 | 显示全部楼层
因为我现在的PC机上安装的就是Ubuntu16.04 ,如果在PC上用rknntoolkit跑仿真程序,还需要把我PC上现有Ubuntu16.04换成Debian10或者Fedora?     感谢!
回复

使用道具 举报

jefferyzhang

超级版主

积分
7596
发表于 2020-9-4 16:15:21 | 显示全部楼层
润城 发表于 2020-9-4 16:11
因为我现在的PC机上安装的就是Ubuntu16.04 ,如果在PC上用rknntoolkit跑仿真程序,还需要把我PC上现有Ubunt ...

不需要。3399Pro板子上跑的是debian10或者android即可
回复

使用道具 举报

润城

注册会员

积分
127
 楼主| 发表于 2020-9-4 16:19:00 | 显示全部楼层
jefferyzhang 发表于 2020-9-4 16:15
不需要。3399Pro板子上跑的是debian10或者android即可

我购买的板子还是Fedora 的Linux版本需要重新更新固件debian10吗?后面不在支持Fedora这个版本了吗? 感谢!
回复

使用道具 举报

jefferyzhang

超级版主

积分
7596
发表于 2020-9-4 17:05:25 | 显示全部楼层
润城 发表于 2020-9-4 16:19
我购买的板子还是Fedora 的Linux版本需要重新更新固件debian10吗?后面不在支持Fedora这个版本了吗? 感 ...

按wiki自己烧成debian10的固件即可
fedora不再做OTA更新了
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表