Toybrick

楼主: jefferyzhang

RK3399Pro入门教程(8)6路1080P30帧解码显示范例

 

jefferyzhang

超级版主

积分
7270
 楼主| 发表于 2020-3-13 08:38:45 | 显示全部楼层
icell 发表于 2020-3-12 21:30
对了大神,1路usb摄像头(1080)解码+1路编码(1080),帧率速度就比1路mipi摄像头(1080)+编码(1080)低很多 ...

先找到速度瓶颈,如果同样的编码,那就是usb速率问题。
你usb摄像头是2.0还是3.0的,算下图像大小和速率就知道了,如果是2.0,1080p根本到不了30fps的。
回复

使用道具 举报

yoyomai

注册会员

积分
51
发表于 2020-3-13 17:51:01 | 显示全部楼层
jefferyzhang 发表于 2020-3-5 20:05
哦,好,我回头做一个单纯whl的

同求,啥时候能出一个?
回复

使用道具 举报

SodrSnne

中级会员

积分
249
发表于 2020-3-16 09:57:03 | 显示全部楼层
楼主你好,这边有些急需python硬解,请问whl的包什么时间能发布
回复

使用道具 举报

jefferyzhang

超级版主

积分
7270
 楼主| 发表于 2020-3-16 10:12:40 | 显示全部楼层
SodrSnne 发表于 2020-3-16 09:57
楼主你好,这边有些急需python硬解,请问whl的包什么时间能发布

嗯?这个包帖子里有写很清楚,这不是官方的包,只是社区爱好者写的,RK没有这个包的任何版权。同样其他客户有没有。如果商业用途请注意版权问题。

不建议用这个做项目,这只是个demo而已,bug很多很多,也不会有人维护,有需求的话请自己开发一个比较稳妥。

debian上的demo近期会更新,没有时间点,这都是业余开发的,我没权利去催人家发布一个非公的包,只能等开发者有空更新。
回复

使用道具 举报

呱唧

注册会员

积分
59
发表于 2020-3-18 23:18:15 | 显示全部楼层
这个对应numpy的版本是多少?import toybrick的时候会报错“ImportError: numpy.core.multiarray failed to import”,搜了一下好像是因为numpy版本过高
回复

使用道具 举报

jefferyzhang

超级版主

积分
7270
 楼主| 发表于 2020-3-19 08:17:46 | 显示全部楼层
呱唧 发表于 2020-3-18 23:18
这个对应numpy的版本是多少?import toybrick的时候会报错“ImportError: numpy.core.multiarray failed to ...

只要你用的是toybrick的系统,不会出现这问题吧,我们都测过了。
numpy没有限制版本,多高都可以。。
回复

使用道具 举报

SodrSnne

中级会员

积分
249
发表于 2020-3-19 13:26:26 | 显示全部楼层
新买的3399板子,烧了debian10系统。跑demo时候发现找不到so文件的错误
请问这个该如何解决,之前在fedro上面运行成功了的

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

jefferyzhang

超级版主

积分
7270
 楼主| 发表于 2020-3-19 14:11:36 | 显示全部楼层
SodrSnne 发表于 2020-3-19 13:26
新买的3399板子,烧了debian10系统。跑demo时候发现找不到so文件的错误
请问这个该如何解决,之前在fedro上 ...

你没仔细看这帖子么,我帖子里已经说了啊,要apt install两个东西啊
回复

使用道具 举报

yoyomai

注册会员

积分
51
发表于 2020-3-19 19:31:20 | 显示全部楼层
jefferyzhang 发表于 2020-3-19 14:11
你没仔细看这帖子么,我帖子里已经说了啊,要apt install两个东西啊

按帖子装上
sudo apt install rockchip-mpp
sudo apt install toybrick-gbm-dev
结果也是和上上楼一样
ImportError: libEGL.so: cannot open shared object file: No such file or directory
请问还需要装什么依赖库?

回复

使用道具 举报

jefferyzhang

超级版主

积分
7270
 楼主| 发表于 2020-3-20 08:25:29 | 显示全部楼层
yoyomai 发表于 2020-3-19 19:31
按帖子装上
sudo apt install rockchip-mpp
sudo apt install toybrick-gbm-dev

请问你的开发版是什么?
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表