Toybrick

楼主: jefferyzhang

[Latest Version] rknn-toolkit-1.2.1 & rknn-api-1.2.0

jefferyzhang

超级版主

积分
2163
 楼主| 发表于 2019-10-30 15:49:34 | 显示全部楼层
米小二 发表于 2019-10-30 15:45
好的 谢谢及时的回复。

rk3399pro的fedora版本还只支持到tf 1.10,无法跟随rk1.2.1升级到rf 1.14?

嗯,因为有个第三方组织在编译aarch64的tensorflow,然后他就只有py3.5和py3.7的。
很不幸的是feodra用的是py3.6,所以没有办法升级上去。
后续我们会把重心转移到 debian10上(py3.7)上
回复

使用道具 举报

几头米

注册会员

积分
67
发表于 2019-10-30 17:17:45 | 显示全部楼层
你好,在输入batch的时候提示:
rknn_input_set, n_inputs = 20, expect 1 !
错误码 -5
请问这可能是什么原因导致的?以及是否有batch输入的c++示例。
API:1.2.0
DRV:0.9.9
输入实现方式与该帖类似:
http://t.rock-chips.com/forum.ph ... &extra=page%3D3
感谢
回复

使用道具 举报

米小二

新手上路

积分
36
发表于 2019-10-30 21:46:49 | 显示全部楼层
HI jeffery.

按照安装说明,我在rk3399上已经升级到了debian,把tensorflow升级到了1.14.但是执行
升级rknn 1.2.1的时候,发现升级失败,是不是你们配置的服务器缺少rknn 1.2.1呢?
Thanks。

---------------------------
toybrick@debian10:~/work/rknn-toolkit-V1.2.1/example/caffe_upsample$ pip3 install --user -U rknn
Looking in indexes: https://pypi.org/simple, http://repo.rock-chips.com/pypi/simple
Collecting rknn
Could not install packages due to an EnvironmentError: 404 Client Error: Not Found for url: https://pypi.org/simple/rknn/


toybrick@debian10:~/work/rknn-toolkit-V1.2.1/example/caffe_upsample$ cat /etc/pip.conf
[global]
extra-index-url = http://repo.rock-chips.com/pypi/simple
trusted-host = repo.rock-chips.com

toybrick@debian10:~/work/rknn-toolkit-V1.2.1/example/caffe_upsample$ pip3 list |grep rknn
rknn-toolkit         1.2.0
回复

使用道具 举报

jefferyzhang

超级版主

积分
2163
 楼主| 发表于 2019-10-30 21:59:53 | 显示全部楼层
米小二 发表于 2019-10-30 21:46
HI jeffery.

按照安装说明,我在rk3399上已经升级到了debian,把tensorflow升级到了1.14.但是执行

你用的是beta版的debian吧?我们正式版还在测试中,还没正式发布。
你现在遇到的问题升级pip后就可以解决,是pip的bug
回复

使用道具 举报

ngawain.j.echo

新手上路

积分
17
发表于 2019-11-1 10:35:11 | 显示全部楼层
debian 的 apt 源 地址 是什么?  
回复

使用道具 举报

jefferyzhang

超级版主

积分
2163
 楼主| 发表于 2019-11-1 11:48:17 | 显示全部楼层
ngawain.j.echo 发表于 2019-11-1 10:35
debian 的 apt 源 地址 是什么?

尽量用debian官方源。我们自己试过ali和清华源很多aarch64的资源并没有涵盖。
RK的源在出版固件里都会自带。
回复

使用道具 举报

jiajia1990

中级会员

积分
219
发表于 2019-11-3 21:06:54 | 显示全部楼层
为什么这样子的?
toybrick@debian10:~/Documents$ sudo apt install rknn-rk3399pro
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E: Unable to locate package rknn-rk3399pro
回复

使用道具 举报

jefferyzhang

超级版主

积分
2163
 楼主| 发表于 2019-11-4 10:01:42 | 显示全部楼层
jiajia1990 发表于 2019-11-3 21:06
为什么这样子的?
toybrick@debian10:~/Documents$ sudo apt install rknn-rk3399pro
Reading package list ...

请等我们debian10正式固件出来,本周内应该就会发布。
在此之前,可以使用本地安装方式执行,请参看wiki。
回复

使用道具 举报

求大佬指教

注册会员

积分
63
发表于 2019-11-4 13:41:45 | 显示全部楼层
jefferyzhang 发表于 2019-10-30 14:55
fedora只能: pip3 install --user -U tensorflow==1.10.0

我上头有写,看你那样子应该已经装了  ...

3399Pro板子上Fedora28只能安装TensorFlow1.10.0吗,不支持最新的1.14吗?
回复

使用道具 举报

jefferyzhang

超级版主

积分
2163
 楼主| 发表于 2019-11-4 14:17:23 | 显示全部楼层
求大佬指教 发表于 2019-11-4 13:41
3399Pro板子上Fedora28只能安装TensorFlow1.10.0吗,不支持最新的1.14吗?

是的,因为我们没找到py3.6版本的 tensorflow-1.14.0 for aarch64
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表