Toybrick

楼主: jefferyzhang

[Latest Version] [1.3.2] rknn-toolkit & [1.3.0] rknn-api for Toybrick

jefferyzhang

超级版主

积分
4770
 楼主| 发表于 2020-2-4 22:03:44 | 显示全部楼层
本帖最后由 jefferyzhang 于 2020-2-4 22:08 编辑
passion 发表于 2020-2-4 21:39
楼主,您好!
谢谢update.
rknn-api-1.3.0

1. 嗯? 没更新是啥意思?这个打开应该就是1.3.0吧?
2. Fedora不再更新,太多人情愿想要ubuntu,所以我们专注在debian10上了,请直接烧debian10的固件。现在这疫情,我们也更没人力去测试fedora了。    Fedora如果有需求,可以参看我们的github自己折腾:https://github.com/rockchip-linux,这个就不属于toybrick社区维护的内容了,所以还是建议尽快升级至debian10
回复

使用道具 举报

qliu

注册会员

积分
162
发表于 2020-2-11 12:13:59 | 显示全部楼层
因为 1.3.0 不止要更新 rknn-toolkit,还要更新 NPU 的 driver,我想确认下更新的方法:
1. 用 rk1808 的话,是按照 http://t.rock-chips.com/wiki.php?mod=view&id=81 这里的说明升级固件吗?rk1808 的最新固件在哪里下载?
2. 用 rk3399pro 的话,如果刷了 Debian10 的固件,driver 还需要手动更新吗?
回复

使用道具 举报

jefferyzhang

超级版主

积分
4770
 楼主| 发表于 2020-2-11 12:16:51 | 显示全部楼层
qliu 发表于 2020-2-11 12:13
因为 1.3.0 不止要更新 rknn-toolkit,还要更新 NPU 的 driver,我想确认下更新的方法:
1. 用 rk1808 的话 ...

如果你用的是toybrick,直接使用内置apt update或者pip3 的update功能即可。
如果你用的不是toybrick的产品,请联系你的代理商升级
回复

使用道具 举报

qliu

注册会员

积分
162
发表于 2020-2-11 17:09:39 | 显示全部楼层
jefferyzhang 发表于 2020-2-11 12:16
如果你用的是toybrick,直接使用内置apt update或者pip3 的update功能即可。
如果你用的不是toybrick的产 ...

我用的是 toybrick 的 rk1808 的计算棒。如何更新 driver 版本呢?
我是用一台 linux PC 连着 rk1808 使用,我看帖子里说用 pip3 install --user -U rknn1808,这个命令是在 linux pc 上执行吗?找不到这个包。
回复

使用道具 举报

jefferyzhang

超级版主

积分
4770
 楼主| 发表于 2020-2-11 17:18:17 | 显示全部楼层
本帖最后由 jefferyzhang 于 2020-2-11 17:20 编辑
qliu 发表于 2020-2-11 17:09
我用的是 toybrick 的 rk1808 的计算棒。如何更新 driver 版本呢?
我是用一台 linux PC 连着 rk1808 使 ...

计算棒的1.3.0还没发布,再稍等一段
回复

使用道具 举报

jefferyzhang

超级版主

积分
4770
 楼主| 发表于 2020-2-11 17:50:39 | 显示全部楼层
qliu 发表于 2020-2-11 17:09
我用的是 toybrick 的 rk1808 的计算棒。如何更新 driver 版本呢?
我是用一台 linux PC 连着 rk1808 使 ...

负责人说已经有了,直接dnf update后就是1.3.0的了
回复

使用道具 举报

mountyang

新手上路

积分
45
发表于 2020-2-14 10:41:57 | 显示全部楼层
jefferyzhang 发表于 2020-2-11 17:50
负责人说已经有了,直接dnf update后就是1.3.0的了

rk3399pro,系统debian 10, apt update apt upgrade以后,rknn版本升级为1.3.0,但是drv版本显示还是0.9.9,这是什么问题?
回复

使用道具 举报

xsky

中级会员

积分
286
发表于 2020-2-14 11:47:28 | 显示全部楼层
rknn-api-1.3.0
下面的百度网盘链接没有更新啊
回复

使用道具 举报

jefferyzhang

超级版主

积分
4770
 楼主| 发表于 2020-2-14 15:15:46 | 显示全部楼层
xsky 发表于 2020-2-14 11:47
rknn-api-1.3.0
下面的百度网盘链接没有更新啊

sorry, 文字更新了超链接没跟着变,现在可以了
回复

使用道具 举报

jefferyzhang

超级版主

积分
4770
 楼主| 发表于 2020-2-14 15:16:18 | 显示全部楼层
mountyang 发表于 2020-2-14 10:41
rk3399pro,系统debian 10, apt update apt upgrade以后,rknn版本升级为1.3.0,但是drv版本显示还是0.9. ...

不应该吧,你是toybrick板子不?其他人都ok了呀
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表