Toybrick

楼主: jefferyzhang

[Latest Version] [1.3.0] rknn-toolkit & rknn-api for Toybrick

SodrSnne

注册会员

积分
135
发表于 2020-2-25 15:45:36 | 显示全部楼层
jefferyzhang 发表于 2020-2-25 14:49
哦,想起来了,fedora是因为1.10是我们自己编译的。。。

在1808计算棒 pip 安装tensorflow==1.10.1时候会提示磁盘空间不足,但是网页看计算棒还有一半的存储空间,这是怎么造成的,切换root安装也出现这个问题.
回复

使用道具 举报

jefferyzhang

超级版主

积分
3675
 楼主| 发表于 2020-2-25 16:22:39 | 显示全部楼层
SodrSnne 发表于 2020-2-25 15:45
在1808计算棒 pip 安装tensorflow==1.10.1时候会提示磁盘空间不足,但是网页看计算棒还有一半的存储空间, ...

用户控件和系统空间不一样,系统空间预留出来有别的用途。
你可以用--user装到用户空间
回复

使用道具 举报

SodrSnne

注册会员

积分
135
发表于 2020-2-26 10:17:39 | 显示全部楼层
jefferyzhang 发表于 2020-2-25 16:22
用户控件和系统空间不一样,系统空间预留出来有别的用途。
你可以用--user装到用户空间 ...

懂了谢谢!
回复

使用道具 举报

lijie

注册会员

积分
85
发表于 2020-2-29 12:42:14 | 显示全部楼层
版主你好

现在似乎toybrick的pypi不能访问,访问会有如下错误:
[global]
extra-index-url = http://repo.rock-chips.com/pypi/simple
trusted-host = repo.rock-chips.com

谢谢!
回复

使用道具 举报

jefferyzhang

超级版主

积分
3675
 楼主| 发表于 2020-2-29 17:21:42 | 显示全部楼层
lijie 发表于 2020-2-29 12:42
版主你好

现在似乎toybrick的pypi不能访问,访问会有如下错误:

参看这个,如果是PC就直接下载whl包装,PC不提供pypi源了
http://t.rock-chips.com/forum.ph ... &extra=page%3D1
回复

使用道具 举报

lijie

注册会员

积分
85
发表于 2020-3-1 16:10:16 | 显示全部楼层
谢谢版主

我的疑问是,之前我们装的python3.7能用pip装rknn-toolkit 1.3.0。然而网上下载的whl包只支持3.5和3.6的。请问网上下载包能提供支持3.7的吗,不然我们还得换python版本?
回复

使用道具 举报

jefferyzhang

超级版主

积分
3675
 楼主| 发表于 2020-3-1 17:56:46 | 显示全部楼层
lijie 发表于 2020-3-1 16:10
谢谢版主

我的疑问是,之前我们装的python3.7能用pip装rknn-toolkit 1.3.0。然而网上下载的whl包只支持3.5 ...

pc版一直没提供过py3.7版本。。。
toybrick debian10是aarch64 py3.7版,其他平台均无该版本
回复

使用道具 举报

lijie

注册会员

积分
85
发表于 2020-3-1 19:14:43 | 显示全部楼层
嗯,我指的是toybrick debian10的py 3.7版,这个版本我们在哪里看一下到3.7的whl包呢?
回复

使用道具 举报

jefferyzhang

超级版主

积分
3675
 楼主| 发表于 2020-3-1 20:32:54 | 显示全部楼层
lijie 发表于 2020-3-1 19:14
嗯,我指的是toybrick debian10的py 3.7版,这个版本我们在哪里看一下到3.7的whl包呢? ...

Toybrick平台参看说明直接升级即可。非Toybrick平台要看NPU部门那边会不会提供
回复

使用道具 举报

kexuejia

新手上路

积分
40
发表于 2020-3-2 13:41:54 | 显示全部楼层
本帖最后由 kexuejia 于 2020-3-2 13:44 编辑

大神你好,请问一下在debian 10上面如何升级rknn版本到1.3.0呢

【通过pip3 install --user -U rknn命令安装,会提示 ERROR: No matching distribution found for rknn】
toybrick@debian10:~/Downloads$ uname -a      
Linux debian10.toybrick 4.4.189 #93 SMP Tue Nov 26 16:40:07 CST 2019 aarch64 GNU/Linux
toybrick@debian10:~/Downloads$ cat /etc/pip.conf
[global]
extra-index-url = http://repo.rock-chips.com/pypi/simple
trusted-host = repo.rock-chips.com
toybrick@debian10:~/Downloads$ pip3 list | grep rknn
rknn-toolkit         1.2.1   
WARNING: You are using pip version 19.3.1; however, version 20.0.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
toybrick@debian10:~/Downloads$ pip3 install --user -U rknn
Looking in indexes: http://repo.rock-chips.com/pypi/simple, https://pypi.tuna.tsinghua.edu.cn/simple
ERROR: Could not find a version that satisfies the requirement rknn (from versions: none)
ERROR: No matching distribution found for rknn
WARNING: You are using pip version 19.3.1; however, version 20.0.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

【从百度云盘上下载whl文件,安装rknn_toolkit-1.3.0-cp36-cp36m-linux_aarch64.whl 也会提示失败】
toybrick@debian10:~/Downloads$ ls
rknn_toolkit-1.3.0-cp36-cp36m-linux_aarch64.whl
toybrick@debian10:~/Downloads$ pip3 install ./rknn_toolkit-1.3.0-cp36-cp36m-linux_aarch64.whl
ERROR: rknn_toolkit-1.3.0-cp36-cp36m-linux_aarch64.whl is not a supported wheel on this platform.
WARNING: You are using pip version 19.3.1; however, version 20.0.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

【更新rknn-rk3399pro也会提示已经是最新版本了】
toybrick@debian10:~/Downloads$ sudo apt install rknn-rk3399pro
Reading package lists... Done
Building dependency tree      
Reading state information... Done
rknn-rk3399pro is already the newest version (1.2.1-1).
0 upgraded, 0 newly installed, 0 to remove and 84 not upgraded.

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表