Toybrick

楼主: jefferyzhang

RK3399Pro入门教程(12)OpenGL/CL在Debian10上的安装和使用

jefferyzhang

超级版主

积分
7973
 楼主| 发表于 2020-3-30 17:06:34 | 显示全部楼层
kaishi 发表于 2020-3-30 16:50
Yes, my clinfo version is 2.2.18.04.06-1 which is older than 2.2.18.04.06-2.
However, I am not abl ...

I think your source.list is not correct.
If you upgrade toybrick debian10 successful, your source.list will be written as below,

toybrick@debian10:~$ cat /etc/apt/sources.list.d/toybrick.list
deb http://repo.rock-chips.com/debian buster main
deb http://repo.rock-chips.com/toybrick/auth-debian buster main
回复

使用道具 举报

kaishi

中级会员

积分
306
发表于 2020-3-31 02:26:48 | 显示全部楼层
jefferyzhang 发表于 2020-3-30 17:06
I think your source.list is not correct.
If you upgrade toybrick debian10 successful, your source. ...

After adding  to source list and the issue is resolved
deb http://repo.rock-chips.com/toybrick/auth-debian buster main.

Thanks for all helps.
回复

使用道具 举报

newcomer3399

注册会员

积分
77
发表于 2020-3-31 10:00:53 | 显示全部楼层
jefferyzhang 发表于 2020-3-30 16:45
我问了工程师了,upgrade完debian10,需要重装clinfo,当你看到的版本是以下一样 2.2.18.04.06-2 就没问 ...

我卸载了clinfo:
sudo apt remove clinfo
然后重新安装
sudo apt install clinfo
然后dpkg -l | grep clinfo
发现软件仍然是-1不是-2
ii  clinfo                                2.2.18.04.06-1                      arm64        Query OpenCL system information
如何解决?
回复

使用道具 举报

jefferyzhang

超级版主

积分
7973
 楼主| 发表于 2020-3-31 10:01:51 | 显示全部楼层
newcomer3399 发表于 2020-3-31 10:00
我卸载了clinfo:
sudo apt remove clinfo
然后重新安装

先更新debian10, update完upgrade,出现提示问你更新source.list点Y,
然后再更新这些就有了
回复

使用道具 举报

newcomer3399

注册会员

积分
77
发表于 2020-3-31 10:07:32 | 显示全部楼层
jefferyzhang 发表于 2020-3-31 10:01
先更新debian10, update完upgrade,出现提示问你更新source.list点Y,
然后再更新这些就有了 ...

我都更新过了。。。难道是我没搞好?
那我再更新一次
回复

使用道具 举报

jefferyzhang

超级版主

积分
7973
 楼主| 发表于 2020-3-31 10:11:44 | 显示全部楼层
newcomer3399 发表于 2020-3-31 10:07
我都更新过了。。。难道是我没搞好?
那我再更新一次

你往上看51楼回复,不行就手动加。
估计是当时更新你把它写了N
回复

使用道具 举报

newcomer3399

注册会员

积分
77
发表于 2020-3-31 10:15:52 | 显示全部楼层
jefferyzhang 发表于 2020-3-31 10:01
先更新debian10, update完upgrade,出现提示问你更新source.list点Y,
然后再更新这些就有了 ...

非常感谢,clinfo信息正常了,但是glmark2不行:
toybrick@debian10:~$ glmark2-es2-drm
glmark2-es2-drm: error while loading shared libraries: libgbm.so: cannot open shared object file: No such file or directory
如何解决
回复

使用道具 举报

jefferyzhang

超级版主

积分
7973
 楼主| 发表于 2020-3-31 10:17:15 | 显示全部楼层
本帖最后由 jefferyzhang 于 2020-3-31 10:18 编辑
newcomer3399 发表于 2020-3-31 10:15
非常感谢,clinfo信息正常了,但是glmark2不行:
toybrick@debian10:~$ glmark2-es2-drm
glmark2-es2-drm ...

你少装了toybrick gbm。
apt里search下应该是这个没装把
sudo apt install toybrick-gbm-dev

回复

使用道具 举报

newcomer3399

注册会员

积分
77
发表于 2020-3-31 10:27:53 | 显示全部楼层
jefferyzhang 发表于 2020-3-31 10:17
你少装了toybrick gbm。
apt里search下应该是这个没装把
sudo apt install toybr ...

sudo apt search toybrick-gbm-dev
Sorting... Done
Full Text Search... Done
toybrick-gbm-dev/stable,now 18.3.6-3 arm64 [installed]
  Development package for Toybrick gbm Libraries
装过了
回复

使用道具 举报

jefferyzhang

超级版主

积分
7973
 楼主| 发表于 2020-3-31 10:30:49 | 显示全部楼层
newcomer3399 发表于 2020-3-31 10:27
sudo apt search toybrick-gbm-dev
Sorting... Done
Full Text Search... Done

sudo apt install libgbm-dev
这个试试
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表