Toybrick

楼主: jefferyzhang

RK3399Pro入门教程(5)图形加速引擎RGA的使用

 

会飞的大白菜

新手上路

积分
35
发表于 2021-9-29 18:30:01 | 显示全部楼层
大佬,你好,我现在做的是一个人脸识别的项目,为了减少cpu的负担,就需要拷贝每一帧的图像进行旋转处理,那么我怎么才能拷贝图像数据,然后进行旋转呢,我看了源代码,不是很能理解,基本上每个操作都需要读的bin文件是什么
回复

使用道具 举报

jefferyzhang

论坛元老

积分
10096
 楼主| 发表于 2021-9-30 09:09:43 | 显示全部楼层
会飞的大白菜 发表于 2021-9-29 18:30
大佬,你好,我现在做的是一个人脸识别的项目,为了减少cpu的负担,就需要拷贝每一帧的图像进行旋转处理, ...

https://github.com/rockchip-linux/linux-rga
用这个官方的rga封装,里头有sample和文档
回复

使用道具 举报

随心

新手上路

积分
8
发表于 2021-11-8 19:24:57 | 显示全部楼层
你好,请问一下rga如何替换videoconvert
回复

使用道具 举报

Ainux

新手上路

积分
29
发表于 2022-1-11 15:27:46 | 显示全部楼层
版主:
        你好!
        此篇文档中的“基础使用流程”中的WIKI教程连接失效,无法打开,可否修改一下?
回复

使用道具 举报

Ainux

新手上路

积分
29
发表于 2022-1-11 15:31:37 | 显示全部楼层
Ainux 发表于 2022-1-11 15:27
版主:
        你好!
        此篇文档中的“基础使用流程”中的WIKI教程连接失效,无法打开,可否修改一 ...

DEBIAN10 librockchip_rga-devel源里无此包?
回复

使用道具 举报

Ainux

新手上路

积分
29
发表于 2022-1-11 15:48:17 | 显示全部楼层
本帖最后由 Ainux 于 2022-1-11 15:56 编辑
Ainux 发表于 2022-1-11 15:31
DEBIAN10 librockchip_rga-devel源里无此包?

DEBIAN10 源中包的名字是rockchip-rga/rockchip-rga-dev/rockchip-rga-dbgsym。
回复

使用道具 举报

gudesheng

新手上路

积分
38
发表于 2022-2-28 17:46:02 | 显示全部楼层
为啥github的官方rga没了
回复

使用道具 举报

btxc_cyy

注册会员

积分
55
发表于 2022-4-8 16:36:26 | 显示全部楼层
链接失效了啊,还有没有人维护这个库?
回复

使用道具 举报

jefferyzhang

论坛元老

积分
10096
 楼主| 发表于 2022-4-8 16:55:26 | 显示全部楼层
btxc_cyy 发表于 2022-4-8 16:36
链接失效了啊,还有没有人维护这个库?

下架审查,toybrick用户直接apt install rockchip-rga即可,其他客户请自行联系代理商或者业务获取
回复

使用道具 举报

btxc_cyy

注册会员

积分
55
发表于 2022-4-13 09:50:38 | 显示全部楼层
jefferyzhang 发表于 2022-4-8 16:55
下架审查,toybrick用户直接apt install rockchip-rga即可,其他客户请自行联系代理商或者业务获取 ...

apt install rockchip-rga后有下面的报错
root@debian10:/home/toybrick# apt install rockchip-rga
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
rockchip-rga : Depends: libc6 (>= 2.29) but 2.28-10+deb10u1 is to be installed
                Depends: libgcc-s1 (>= 3.0) but it is not installable
E: Unable to correct problems, you have held broken packages.
这个时已经更新过源之后的,用的也是官方给的debian10,这个有什么解决办法吗
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表