Toybrick

RK1808 M0 升级RKNN-rk1808 1.7版本失败

yqy0805

新手上路

积分
32
发表于 2022-3-8 20:59:14    查看: 3497|回复: 7 | [复制链接]    打印 | 显示全部楼层
RK1808 M0
ssh 进行rknn的安装,提示 opencl库问题。
把原来的rknn-rk1808 1.5 卸掉了。sudo apt remove rknn-rk1808. 再也装不回去了。
哪里有原版的安装包可以下载?
Thanks
回复

使用道具 举报

jefferyzhang

版主

积分
12935
发表于 2022-3-9 09:03:29 | 显示全部楼层
WIKI看一眼啊,
https://t.rock-chips.com/wiki.ph ... 9%E4%B8%8B%E8%BD%BD
1808M0可以直接重烧固件
回复

使用道具 举报

yqy0805

新手上路

积分
32
 楼主| 发表于 2022-3-9 09:09:31 | 显示全部楼层
jefferyzhang 发表于 2022-3-9 09:03
WIKI看一眼啊,
https://t.rock-chips.com/wiki.php?filename=%E8%B5%84%E6%96%99%E4%B8%8B%E8%BD%BD/%E8%B ...

刚拿到手,就烧固件,怕弄坏了。。能否提供一个安装包?
回复

使用道具 举报

yqy0805

新手上路

积分
32
 楼主| 发表于 2022-3-9 09:12:33 | 显示全部楼层
yqy0805 发表于 2022-3-9 09:09
刚拿到手,就烧固件,怕弄坏了。。能否提供一个安装包?

或是是编译好的文件和头文件,以及安装的路径也行。
回复

使用道具 举报

jefferyzhang

版主

积分
12935
发表于 2022-3-9 09:24:22 | 显示全部楼层
不要去擦除全盘,直接烧,不可能烧坏。
所有安装包都在apt上,装不上就是依赖被破坏了。
有些东西不是安装包能解决的,依赖被破坏了你没这能力去折腾。
回复

使用道具 举报

yqy0805

新手上路

积分
32
 楼主| 发表于 2022-3-9 10:30:40 | 显示全部楼层
jefferyzhang 发表于 2022-3-9 09:24
不要去擦除全盘,直接烧,不可能烧坏。
所有安装包都在apt上,装不上就是依赖被破坏了。
有些东西不是安装 ...

apt上rknn-rk1808只有1.7.1, rank-sample 1.6
rknn-rk1808 能否上传一个1.5版本?
Thanks
回复

使用道具 举报

yqy0805

新手上路

积分
32
 楼主| 发表于 2022-3-9 13:38:07 | 显示全部楼层
jefferyzhang 发表于 2022-3-9 09:24
不要去擦除全盘,直接烧,不可能烧坏。
所有安装包都在apt上,装不上就是依赖被破坏了。
有些东西不是安装 ...

用的v2.1 固件。
在rknn-rk1808 升级1.7的时候
报:
dpkg: error processing archive /tmp/apt-dpkg-install-Lzvapy/44-rknn-rk1808_1.7.1-1_arm64.deb (--unpack):
trying to overwrite '/usr/lib/aarch64-linux-gnu/libOpenCL.so.1', which is also in package ocl-icd-libopencl1:arm64 2.2.12-2
回复

使用道具 举报

christlurker

新手上路

积分
42
发表于 2022-4-26 17:22:52 | 显示全部楼层
yqy0805 发表于 2022-3-9 13:38
用的v2.1 固件。
在rknn-rk1808 升级1.7的时候
报:

我也碰到了相同的问题
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表