Toybrick

rk1808被动调用报错,请大神指导

wudiking

高级会员

积分
689
发表于 2022-5-5 11:11:14    查看: 4009|回复: 6 | [复制链接]    打印 | 显示全部楼层
PC机安装debian9系统,并部署rknn1.7.1版本,通过pc的u口连接RK1808板卡,RK1808板卡rknn版本是1.2.0版本
执行rknn.bin.list_devices获取U口连接的RK1808的设备ID,修改rknn的例子,将init_runtime函数接口增加target,
及device_id参数,并执行,报ERR_MODEL_INVALID
                                               
done
--> Export RKNN model
done
--> Init runtime environment
I NPUTransfer: Starting NPU Transfer Client, Transfer version 2.1.0 (b5861e7@2020-11-23T11:50:36)
E RKNNAPI: rknn_init,  msg_load_ack fail, ack = 1(ACK_FAIL), expect 0(ACK_SUCC)!
E RKNNAPI: ==============================================
E RKNNAPI: RKNN VERSION:
E RKNNAPI:   API: 1.7.1 (566a9b6 build: 2021-10-28 14:53:41)
E RKNNAPI:   DRV: 1.2.0 (57b1656 build: 2019-09-04 09:27:47)
E RKNNAPI: ==============================================
E Catch exception when init runtime!
E Traceback (most recent call last):
E   File "rknn/api/rknn_base.py", line 897, in rknn.api.rknn_base.RKNNBase.init_runtime
E   File "rknn/api/rknn_runtime.py", line 341, in rknn.api.rknn_runtime.RKNNRuntime.build_graph
E Exception: RKNN init failed. error code: RKNN_ERR_MODEL_INVALID
E Please feedback the detailed log file <log_feedback_to_the_rknn_toolkit_dev_team.log> to the RKNN Toolkit development team.
E You can also check github issues: https://github.com/rockchip-linux/rknn-toolkit/issues
E Current device id is: TB-RK1808S0
E Devices connected:
E ['TB-RK1808S0']



回复

使用道具 举报

wudiking

高级会员

积分
689
 楼主| 发表于 2022-5-5 11:13:24 | 显示全部楼层
请大神,给分析一下出错原因,给出解决方法
回复

使用道具 举报

jefferyzhang

版主

积分
13012
发表于 2022-5-5 11:40:14 | 显示全部楼层
出问题文档先看下,这里这么明显的问题,DRV和API都不匹配,差了整整2年的版本,咋可能跑得起来

E RKNNAPI:   API: 1.7.1 (566a9b6 build: 2021-10-28 14:53:41)
E RKNNAPI:   DRV: 1.2.0 (57b1656 build: 2019-09-04 09:27:47)
回复

使用道具 举报

wudiking

高级会员

积分
689
 楼主| 发表于 2022-5-5 12:08:04 | 显示全部楼层
jefferyzhang 发表于 2022-5-5 11:40
出问题文档先看下,这里这么明显的问题,DRV和API都不匹配,差了整整2年的版本,咋可能跑得起来

E RKNNAPI ...

drv想更换1.7.1,可是需要固件支持,我在论坛上看到的最新版本固件,带的是1.3.2版本的rknn,请问有支持最新版本rknn的固件吗
回复

使用道具 举报

jefferyzhang

版主

积分
13012
发表于 2022-5-5 12:12:15 | 显示全部楼层
wudiking 发表于 2022-5-5 12:08
drv想更换1.7.1,可是需要固件支持,我在论坛上看到的最新版本固件,带的是1.3.2版本的rknn,请问有支持 ...

你这是什么产品啊?计算棒的话自身可以OTA升级到171的,wiki看一下啊
回复

使用道具 举报

wudiking

高级会员

积分
689
 楼主| 发表于 2022-5-5 12:35:20 | 显示全部楼层
jefferyzhang 发表于 2022-5-5 12:12
你这是什么产品啊?计算棒的话自身可以OTA升级到171的,wiki看一下啊

我现在用的是TB16A-AI,直接连的1808的u口
回复

使用道具 举报

wudiking

高级会员

积分
689
 楼主| 发表于 2022-5-5 12:41:40 | 显示全部楼层
jefferyzhang 发表于 2022-5-5 12:12
你这是什么产品啊?计算棒的话自身可以OTA升级到171的,wiki看一下啊

之前使用宿主机web升级过一次,但升级失败,系统起不来了,使用烧写工具升级了论坛里最新的固件,发现里面rknn是1.3.2,没找到与1.7.1对应的固件版本
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表