Toybrick

rk35588开发板无法apt update的问题

xzx

新手上路

积分
25
发表于 2022-5-11 10:32:23    查看: 258|回复: 8 | [复制链接]    打印 | 显示全部楼层
新买的rk3588开发板,自带的debian11操作系统,开机后想要配置下自己要用的环境,所以就正常执行了sudo apt update,更新软件源操作,结果会一直报同一个错误,截图所示:系统网络是正常的,可以正常上网,用的就是自带浏览器搜索解决方案。
网上说的最多的解决方案就是更新源,但我试了几乎所有能找到的源,都没用。还有的说是DNS服务器的问题,也尝试了一些方案,失败。所以在这发帖求助下,感激解答。



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

395876134

版主

积分
839
发表于 2022-5-11 10:43:19 | 显示全部楼层
多试几次?都不行么
回复

使用道具 举报

addy

超级版主

积分
591
发表于 2022-5-11 10:54:05 | 显示全部楼层
Do you want to accepted .... [Y/n]
请选择 Y
然后再次执行sudo apt update

或者从以下链接下载最新镜像:
https://eyun.baidu.com/s/3dGofGR ... ges%2FLinux%20image
回复

使用道具 举报

xzx

新手上路

积分
25
 楼主| 发表于 2022-5-11 12:05:49 | 显示全部楼层
addy 发表于 2022-5-11 10:54
Do you want to accepted .... [Y/n]
请选择 Y
然后再次执行sudo apt update

这个链接中的文件2个多G啊,这么大。下好了看看
手动敲了个y字母竟然就可以了!!真实的颠覆认知了,原来操作过程中这个【Y/n】选项需要打字母Y的吗?!!   我一直以为直接敲回车就默认y了,之前装啥软件基本上也是这样。真没想到是这个问题。
多谢解答!!!
回复

使用道具 举报

xzx

新手上路

积分
25
 楼主| 发表于 2022-5-11 15:17:07 | 显示全部楼层
addy 发表于 2022-5-11 10:54
Do you want to accepted .... [Y/n]
请选择 Y
然后再次执行sudo apt update

现在update成功了,但是我尝试sudo apt upgrade 又报了这个错,缺少这个qt5-default文件,这个是我安装的相机驱动的依赖库,没有它相机驱动无法安装成功,求助下碰到这种情况的话应该怎么解决呢?!C:\Users\60392\Desktop\1.jpgC:\Users\60392\Desktop\3.jpg
回复

使用道具 举报

xzx

新手上路

积分
25
 楼主| 发表于 2022-5-11 15:26:00 | 显示全部楼层
限制发图了.
回复

使用道具 举报

xzx

新手上路

积分
25
 楼主| 发表于 2022-5-11 15:28:26 | 显示全部楼层
就是E: package “qt5-default” has no installation candidate
回复

使用道具 举报

addy

超级版主

积分
591
发表于 2022-5-11 20:48:38 | 显示全部楼层
debian11源码包里面没有qt5-default,请自己从源码编译。

另外,这个提示信息,是deiban11写apt软件的人设定的。要是不习惯,你可以自己修改。
都是源码,你可以下载修改,打包。你想什么改就什么改。
回复

使用道具 举报

xzx

新手上路

积分
25
 楼主| 发表于 2022-5-12 11:04:43 | 显示全部楼层
addy 发表于 2022-5-11 20:48
debian11源码包里面没有qt5-default,请自己从源码编译。

另外,这个提示信息,是deiban11写apt软件的人设 ...

好的,多谢回复。
我在系统上搭建opencv安装环境时,需要依赖jiasper的库文件,Debian11系统上没有,按照你说的我在网络上找,但是根本就找不到对应arm64平台的jasper包,之前3399上装的Debian10,安装opencv都不需要手动装这个库
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表