Toybrick

rv1126驱动从1.6.1升级到1.7.1

AI_XIEQF

新手上路

积分
35
发表于 2022-6-19 15:20:13    查看: 313|回复: 0 | [复制链接]    打印 | 显示全部楼层
我把板子的驱动从1.6.1升级到1.7.1,报错
升级步骤如下:
1.        把https://github.com/rockchip-linu ... inux-armhf-puma/usr push到板子的对应目录。  2.        把https://github.com/rockchip-linu ... _ko/galcore_puma.ko改名为galcore.ko, push到板子/lib/modules/galcore.ko。可以先在板子上find下原来galcore.ko的位置。  3.        重启板子。
升级完成之后需要到/usr/lib目录下用下面三个命令做一下软链接。
1.        [root@RV1126_RV1109:/usr/lib]# ln -snf libOpenVX.so.1.2 libOpenVX.so.1  2.        [root@RV1126_RV1109:/usr/lib]# ln -snf libOpenVX.so.1 libOpenVX.so  3.        [root@RV1126_RV1109:/usr/lib]# ln -snf libOpenCL.so.1.2 libOpenCL.so.1  

在完成上述操作后,在pc连接板子npu转模型,使用rknn-toolkit1.7.1,onnx->rknn报如下错误:--> Config model
done
--> Loading model
W Call onnx.optimizer.optimize fail, skip optimize
W:tensorflow:From /home/xie/anaconda3/envs/rknn/lib/python3.6/site-packages/rknn/api/rknn.py:150: The name tf.ConfigProto is deprecated. Please use tf.compat.v1.ConfigProto instead.

W:tensorflow:From /home/xie/anaconda3/envs/rknn/lib/python3.6/site-packages/rknn/api/rknn.py:150: The name tf.Session is deprecated. Please use tf.compat.v1.Session instead.

W:tensorflow:From /home/xie/anaconda3/envs/rknn/lib/python3.6/site-packages/rknn/api/rknn.py:150: The name tf.placeholder is deprecated. Please use tf.compat.v1.placeholder instead.

done
--> Building model
done
--> Export RKNN model
done
--> Init runtime environment
I NPUTransfer: Starting NPU Transfer Client, Transfer version 2.1.0 (b5861e7@2020-11-23T11:50:36)
E RKNNAPI: rknn_init,  recv(MsgLoadAck) fail, -9(ERROR_PIPE) != 368!
E Catch exception when init runtime!
E Traceback (most recent call last):
E   File "rknn/api/rknn_base.py", line 897, in rknn.api.rknn_base.RKNNBase.init_runtime
E   File "rknn/api/rknn_runtime.py", line 341, in rknn.api.rknn_runtime.RKNNRuntime.build_graph
E Exception: RKNN init failed. error code: RKNN_ERR_DEVICE_UNAVAILABLE
E Please feedback the detailed log file <log_feedback_to_the_rknn_toolkit_dev_team.log> to the RKNN Toolkit development team.
E You can also check github issues: https://github.com/rockchip-linux/rknn-toolkit/issues
E Current device id is: c607a1d1531403d3
E Devices connected:
E ['c607a1d1531403d3']
Init runtime environment failed


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表