Toybrick

scripy-1.2.0-cp36-cp36m-linux_aarch64.whl安装一直报错

xiaochou

新手上路

积分
47
发表于 2019-7-14 13:47:25    查看: 8536|回复: 5 | [复制链接]    打印 | 显示全部楼层
请问我用固件v1.3版本下载镜像到开发板,开机之后就按照模型转换教程进行安装包,第一条和第二条里面的包都有了,但是numpy,onnx,tensorflow安装过程中一直报错,我把scripy-1.2.0-cp36-cp36m-linux_aarch64.whl放进开发板桌面,cd到桌面,pip3 install --user 文件名
报错could not find a version that satifies the requirement scripy-1.2.0-cp36-cp36m-linux_aarch64:
No matching distribution found for scripy-1.2.0-cp36-cp36m-linux_aarch64
pip3原来是9.0.3,已经进行更新,更新完还是9.0.3版本
试过豆瓣和清华源都是报同样的错误
是网络连接或者设置问题吗?还是源里面都没有?麻烦各位指教一下,不胜感激。

回复

使用道具 举报

xiaochou

新手上路

积分
47
 楼主| 发表于 2019-7-14 16:02:49 | 显示全部楼层
scipy打错了,请问有什么好的解决方法吗
回复

使用道具 举报

jefferyzhang

版主

积分
13113
发表于 2019-7-15 08:20:43 | 显示全部楼层
能用dnf安装的,都用dnf install来装,不要用pip3.
pip3对aarch64环境支持的不是很好。dnf search下你要的py3的包看看有没有先
回复

使用道具 举报

zhangzj

超级版主

积分
1117
发表于 2019-7-15 09:00:33 | 显示全部楼层
V1.3版本的固件应该已经把rknn-toolkit和所依赖的包都预装好了
回复

使用道具 举报

shopping

中级会员

积分
410
发表于 2019-9-16 15:43:43 | 显示全部楼层
jefferyzhang 发表于 2019-7-15 08:20
能用dnf安装的,都用dnf install来装,不要用pip3.
pip3对aarch64环境支持的不是很好。dnf search下你要的p ...

debian9系统下,apt 下载的依赖库包大多版本老旧,而且 apt install 是下载到 python2.7下的。
回复

使用道具 举报

jefferyzhang

版主

积分
13113
发表于 2019-9-17 09:07:09 | 显示全部楼层
shopping 发表于 2019-9-16 15:43
debian9系统下,apt 下载的依赖库包大多版本老旧,而且 apt install 是下载到 python2.7下的。 ...

我们社区仅发布和支持Fedora系统
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表