Toybrick

楼主: jefferyzhang

[Latest Version] [1.6.1] rknn-toolkit & rknn-api for Toybrick

 

wanggang

新手上路

积分
24
发表于 2021-1-21 13:11:18 | 显示全部楼层
wanggang 发表于 2021-1-21 13:06
请问楼主,RKNN1.6.0需要RK3399pro升级NPU的FW吗? 目前时NPU v1.3.1,可以支持RKNN1.6.0吗? ...

rknn-toolkit  v1.4.0和 NPU FW v1.3.1可以正常工作。但是
rknn-toolkit  v1.6.0和 NPU FW v1.3.1不行
回复

使用道具 举报

jefferyzhang

论坛元老

积分
8614
 楼主| 发表于 2021-1-21 14:08:20 | 显示全部楼层
wanggang 发表于 2021-1-21 13:06
请问楼主,RKNN1.6.0需要RK3399pro升级NPU的FW吗? 目前时NPU v1.3.1,可以支持RKNN1.6.0吗? ...

部分支持
回复

使用道具 举报

lidd

新手上路

积分
31
发表于 2021-1-26 11:57:16 | 显示全部楼层

linaro@linaro-alip:~$ sudo apt install rknn-rk3399pro
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E: Unable to locate package rknn-rk3399pro
qing wen zhe ge wen ti ru he jie jue ne?
回复

使用道具 举报

jefferyzhang

论坛元老

积分
8614
 楼主| 发表于 2021-1-26 12:34:07 | 显示全部楼层
lidd 发表于 2021-1-26 11:57
linaro@linaro-alip:~$ sudo apt install rknn-rk3399pro
Reading package lists... Done
Building depen ...

不明白你问的问题,你这明显不是toybrick的板子,为什么用这种奇怪的安装命令
回复

使用道具 举报

lidd

新手上路

积分
31
发表于 2021-1-26 14:11:02 | 显示全部楼层
jefferyzhang 发表于 2021-1-26 12:34
不明白你问的问题,你这明显不是toybrick的板子,为什么用这种奇怪的安装命令 ...

--> Init runtime environment
*************************
all device(s) with ntb mode:
7ddd616377fefe09
*************************
([], ['7ddd616377fefe09'])
E Only support ntb mode on ARM64 platform. But can not find device with ntb mode.
E Catch exception when init runtime!
E Traceback (most recent call last):
E   File "rknn/api/rknn_base.py", line 815, in rknn.api.rknn_base.RKNNBase.init_runtime
E   File "rknn/api/rknn_runtime.py", line 170, in rknn.api.rknn_runtime.RKNNRuntime.__init__
E   File "rknn/api/rknn_platform_utils.py", line 307, in rknn.api.rknn_platform_utils.start_ntp_or_adb
E Exception: Init runtime environment failed!
E Current device id is: 7ddd616377fefe09
E Devices connected:
E ['7ddd616377fefe09']
Init runtime environment failed
在运行mobilev1里的测试程序时出现了 请问这个问题怎么解决
回复

使用道具 举报

lidd

新手上路

积分
31
发表于 2021-1-26 14:14:58 | 显示全部楼层
jefferyzhang 发表于 2021-1-26 12:34
不明白你问的问题,你这明显不是toybrick的板子,为什么用这种奇怪的安装命令 ...

这个安装命令 是您的帖子里提供的啊 是您发的帖子啊
回复

使用道具 举报

jefferyzhang

论坛元老

积分
8614
 楼主| 发表于 2021-1-26 14:45:11 | 显示全部楼层
lidd 发表于 2021-1-26 14:14
这个安装命令 是您的帖子里提供的啊 是您发的帖子啊

我们是toybrick的团队,所有命令和教学只适用于toybrick开发版。
PC可直接通过开源连接下载,
其他开发版请联系其他代理商
回复

使用道具 举报

wanggang

新手上路

积分
24
发表于 2021-1-29 10:04:47 | 显示全部楼层
wanggang 发表于 2021-1-21 13:11
rknn-toolkit  v1.4.0和 NPU FW v1.3.1可以正常工作。但是
rknn-toolkit  v1.6.0和 NPU FW v1.3.1不行
...

谢谢,请问rknn-toolkit  v1.6.0需要哪个版本的NPU FW?
回复

使用道具 举报

wanggang

新手上路

积分
24
发表于 2021-2-2 18:21:57 | 显示全部楼层
打扰楼主一下,
请问rknn-toolkit  v1.6.0需要哪个版本的NPU FW?
回复

使用道具 举报

jefferyzhang

论坛元老

积分
8614
 楼主| 发表于 2021-2-3 08:34:22 | 显示全部楼层
wanggang 发表于 2021-2-2 18:21
打扰楼主一下,
请问rknn-toolkit  v1.6.0需要哪个版本的NPU FW?

大于等于1.5。
1.6还在测试版状态,会不断修改bug,模型非要1.6才能转换的过的可以试试
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表