Toybrick

使用opengles3.0做视频渲染,egl初始化失败

cxjrk

中级会员

积分
336
发表于 2020-6-16 18:58:14    查看: 26680|回复: 10 | [复制链接]    打印 | 显示全部楼层
使用opengles3.0做视频渲染,egl初始化失败,调用接口eglInitialize返回false,请问可能是什么原因呢
回复

使用道具 举报

cxjrk

中级会员

积分
336
 楼主| 发表于 2020-6-16 19:38:54 | 显示全部楼层
2.0版本也是同样问题,可能不是opengles版本问题
回复

使用道具 举报

leok

版主

积分
894
发表于 2020-6-17 08:33:41 | 显示全部楼层
cxjrk 发表于 2020-6-16 19:38
2.0版本也是同样问题,可能不是opengles版本问题

把具体错误打出来。然后再去分析。
int  _err = eglGetError();
回复

使用道具 举报

cxjrk

中级会员

积分
336
 楼主| 发表于 2020-6-17 08:34:49 | 显示全部楼层
leok 发表于 2020-6-17 08:33
把具体错误打出来。然后再去分析。
int  _err = eglGetError();

这个我用过,返回值是0,就是false
回复

使用道具 举报

jefferyzhang

版主

积分
13111
发表于 2020-6-17 08:46:13 | 显示全部楼层
cxjrk 发表于 2020-6-17 08:34
这个我用过,返回值是0,就是false

不会写GL代码就参考glmark2的源码。
嵌入式开发跟PC开发不一样,初始化是需要去getNativeDisplay的
回复

使用道具 举报

leok

版主

积分
894
发表于 2020-6-17 08:47:59 | 显示全部楼层
cxjrk 发表于 2020-6-17 08:34
这个我用过,返回值是0,就是false

再查下,是不是display拿错了。
回复

使用道具 举报

cxjrk

中级会员

积分
336
 楼主| 发表于 2020-6-17 09:40:35 | 显示全部楼层
jefferyzhang 发表于 2020-6-17 08:46
不会写GL代码就参考glmark2的源码。
嵌入式开发跟PC开发不一样,初始化是需要去getNativeDisplay的 ...

好的,正在研究glmark2源码
回复

使用道具 举报

cxjrk

中级会员

积分
336
 楼主| 发表于 2020-6-17 09:42:56 | 显示全部楼层
leok 发表于 2020-6-17 08:47
再查下,是不是display拿错了。

display那边传的参数是EGL_DEFAULT_DISPLAY,获取到的display不是EGL_NO_DISPLAY,传给eglInitialize的时候就返回0。
回复

使用道具 举报

cxjrk

中级会员

积分
336
 楼主| 发表于 2020-6-17 17:12:55 | 显示全部楼层
leok 发表于 2020-6-17 08:47
再查下,是不是display拿错了。

我查了下,如果在eglGetDisplay的时候不用default,该接口返回EGL_NO_DISPLAY,调用geterror返回success,E:\data\121.jpg
回复

使用道具 举报

rensichao

注册会员

积分
89
发表于 2021-11-9 15:21:58 | 显示全部楼层
cxjrk 发表于 2020-6-17 17:12
我查了下,如果在eglGetDisplay的时候不用default,该接口返回EGL_NO_DISPLAY,调用geterror返回success, ...

我遇到同样的问题,请问后来解决了吗?
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表