Toybrick

3399pro(6G内存)板子上无法安装RKNN-TOOL0.98

qiaoqiang126

中级会员

积分
225
发表于 2019-3-1 15:05:47    查看: 20798|回复: 13 | [复制链接]    打印 | 显示全部楼层
TENSORFLOW 和RKNN-TOOL都没有安装在usr/local/lib64下面,而是安装到其他目录下面了。这是怎么回事?
回复

使用道具 举报

jefferyzhang

版主

积分
13194
发表于 2019-3-1 15:16:55 | 显示全部楼层
这两个都是python的,为什么要装到usr/local/lib64下?
回复

使用道具 举报

qiaoqiang126

中级会员

积分
225
 楼主| 发表于 2019-3-1 15:34:08 | 显示全部楼层
jefferyzhang 发表于 2019-3-1 15:16
这两个都是python的,为什么要装到usr/local/lib64下?

python3.6的包都应该在usr/local/lib64/python3.6/site-XXXXXXXXXXXXXXXX下面啊,不然怎么调用
回复

使用道具 举报

leok

版主

积分
894
发表于 2019-3-1 15:52:25 | 显示全部楼层
qiaoqiang126 发表于 2019-3-1 15:34
python3.6的包都应该在usr/local/lib64/python3.6/site-XXXXXXXXXXXXXXXX下面啊,不然怎么调用 ...

这位同学,要看安装包在哪里,这里以3.6为例,可以敲pip3.6 show xxxx
想看rknn装在哪里,敲: pip3.6 show rknn-toolkit
默认一般是安装在 ~/.local/lib/python3.6/site-packages/
回复

使用道具 举报

qiaoqiang126

中级会员

积分
225
 楼主| 发表于 2019-3-1 15:56:15 | 显示全部楼层
leok 发表于 2019-3-1 15:52
这位同学,要看安装包在哪里,这里以3.6为例,可以敲pip3.6 show xxxx
想看rknn装在哪里,敲: pip3.6 sho ...

可是安在~/.local/lib/python3.6/site-packages/   下面,import rknn 无法导入。。。。no module named rknn.......
回复

使用道具 举报

leok

版主

积分
894
发表于 2019-3-1 16:09:05 | 显示全部楼层
qiaoqiang126 发表于 2019-3-1 15:56
可是安在~/.local/lib/python3.6/site-packages/   下面,import rknn 无法导入。。。。no module named  ...

1、先确认安装的版本,我猜你是安装在3.6下,然后用2.7或者其他版本的python去import rknn的;
2、可以先确认是安装在python哪个版本下;比如pip3.6 show rknn-toolkit会得到如下结果:
Name: rknn-toolkit
Version: 0.9.8.1
Summary: Rockchip Neural Network Toolkit
Home-page: UNKNOWN
Author: Rockchip
Author-email: None
License: UNKNOWN
Location: /home/toybrick/.local/lib/python3.6/site-packages
Requires: numpy, flask, onnx, Pillow, dill, lmdb, scipy, networkx, protobuf, flatbuffers, h5py
那么是安装在3.6下;
3、再确认默认python版本,python --version是否是3.6,如默认不是3.6那么可以这么做,python3.6 xxx.py跑你的脚本,或者在脚本中指定用python3.6,#!/usr/bin/python3.6 ;

这些都是比较基础的东西,希望同学一起共同进步奥~~
回复

使用道具 举报

qiaoqiang126

中级会员

积分
225
 楼主| 发表于 2019-3-1 16:15:13 | 显示全部楼层
leok 发表于 2019-3-1 16:09
1、先确认安装的版本,我猜你是安装在3.6下,然后用2.7或者其他版本的python去import rknn的;
2、可以先 ...

[toybrick@localhost ~]$ sudo pip3.6 show rknn-toolkit
Name: rknn-toolkit
Version: 0.9.8
Summary: Rockchip Neural Network Toolkit
Home-page: UNKNOWN
Author: Rockchip
Author-email: None
License: UNKNOWN
Location: /root/.local/lib/python3.6/site-packages
Requires: Pillow, flatbuffers, protobuf, numpy, dill, flask, networkx, scipy, lm                                                                                                 db, onnx, h5py


[toybrick@localhost ~]$ python
Python 3.6.8 (default, Jan 31 2019, 09:06:51)
[GCC 8.2.1 20181215 (Red Hat 8.2.1-6)] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import rknn
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ModuleNotFoundError: No module named 'rknn'
>>>


回复

使用道具 举报

chuyee

中级会员

积分
352
发表于 2019-3-1 16:16:37 | 显示全部楼层
qiaoqiang126 发表于 2019-3-1 15:56
可是安在~/.local/lib/python3.6/site-packages/   下面,import rknn 无法导入。。。。no module named  ...

I guess you run pip with normal user or "--user", right? If you run pip as root it will be installed in the system path.
回复

使用道具 举报

qiaoqiang126

中级会员

积分
225
 楼主| 发表于 2019-3-1 16:23:45 | 显示全部楼层
chuyee 发表于 2019-3-1 16:16
I guess you run pip with normal user or "--user", right? If you run pip as root it will be install ...

sudo pip3 install /home/toybrick/packages/tensorflow-1.10.1-cp36-cp36m-linux_aarch64.whl  我用的是这个命令
回复

使用道具 举报

leok

版主

积分
894
发表于 2019-3-1 16:31:42 | 显示全部楼层
qiaoqiang126 发表于 2019-3-1 16:15
[toybrick@localhost ~]$ sudo pip3.6 show rknn-toolkit
Name: rknn-toolkit
Version: 0.9.8

sudo python 之后在 import rknn试看看
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表