Toybrick

Windows无法运行Yolov3 demo

qk-007

新手上路

积分
11
发表于 2019-10-24 11:45:45    查看: 8428|回复: 1 | [复制链接]    打印 | 显示全部楼层
PS C:\Users\xh\Downloads\win_rknn_env\yolov3> python .\rknn_camera_tiny_multiProcess.py
Traceback (most recent call last):
  File ".\rknn_camera_tiny_multiProcess.py", line 8, in <module>
    from rknn.api import RKNN
  File "D:\Python-3.6.8\lib\site-packages\rknn\__init__.py", line 1, in <module>
    from rknn import api
  File "D:\Python-3.6.8\lib\site-packages\rknn\api\__init__.py", line 1, in <module>
    from rknn.api.rknn import RKNN
  File "D:\Python-3.6.8\lib\site-packages\rknn\api\rknn.py", line 16, in <module>
    from .rknn_base import RKNNBase
  File "rknn\api\rknn_base.py", line 21, in init rknn.api.rknn_base
  File "rknn\base\acuitylib\converter\convert_tf.py", line 11, in init rknn.base.acuitylib.converter.convert_tf
  File "rknn\base\acuitylib\converter\tensorflowloader.py", line 22, in init rknn.base.acuitylib.converter.tensorflowloader
  File "rknn\base\acuitylib\converter\tensor_model.py", line 4, in init rknn.base.acuitylib.converter.tensor_model
  File "rknn\base\acuitylib\converter\onnx_util.py", line 7, in init rknn.base.acuitylib.converter.onnx_util
  File "D:\Python-3.6.8\lib\site-packages\onnx_tf\__init__.py", line 1, in <module>
    from . import frontend
  File "D:\Python-3.6.8\lib\site-packages\onnx_tf\frontend.py", line 18, in <module>
    from onnx_tf.common.handler_helper import get_all_frontend_handlers
  File "D:\Python-3.6.8\lib\site-packages\onnx_tf\common\handler_helper.py", line 5, in <module>
    from onnx_tf.handlers.backend import *  # noqa
  File "D:\Python-3.6.8\lib\site-packages\onnx_tf\handlers\backend\ceil.py", line 10, in <module>
    @tf_func(tf.ceil)
AttributeError: module 'tensorflow' has no attribute 'ceil'
PS C:\Users\xh\Downloads\win_rknn_env\yolov3> python .\rknn_camera_tiny_multiProcess.py
Traceback (most recent call last):
  File ".\rknn_camera_tiny_multiProcess.py", line 8, in <module>
    from rknn.api import RKNN
  File "D:\Python-3.6.8\lib\site-packages\rknn\__init__.py", line 1, in <module>
    from rknn import api
  File "D:\Python-3.6.8\lib\site-packages\rknn\api\__init__.py", line 1, in <module>
    from rknn.api.rknn import RKNN
  File "D:\Python-3.6.8\lib\site-packages\rknn\api\rknn.py", line 16, in <module>
    from .rknn_base import RKNNBase
  File "rknn\api\rknn_base.py", line 21, in init rknn.api.rknn_base
  File "rknn\base\acuitylib\converter\convert_tf.py", line 11, in init rknn.base.acuitylib.converter.convert_tf
  File "rknn\base\acuitylib\converter\tensorflowloader.py", line 22, in init rknn.base.acuitylib.converter.tensorflowloader
  File "rknn\base\acuitylib\converter\tensor_model.py", line 4, in init rknn.base.acuitylib.converter.tensor_model
  File "rknn\base\acuitylib\converter\onnx_util.py", line 7, in init rknn.base.acuitylib.converter.onnx_util
  File "D:\Python-3.6.8\lib\site-packages\onnx_tf\__init__.py", line 1, in <module>
    from . import frontend
  File "D:\Python-3.6.8\lib\site-packages\onnx_tf\frontend.py", line 18, in <module>
    from onnx_tf.common.handler_helper import get_all_frontend_handlers
  File "D:\Python-3.6.8\lib\site-packages\onnx_tf\common\handler_helper.py", line 5, in <module>
    from onnx_tf.handlers.backend import *  # noqa
  File "D:\Python-3.6.8\lib\site-packages\onnx_tf\handlers\backend\ceil.py", line 10, in <module>
    @tf_func(tf.ceil)
AttributeError: module 'tensorflow' has no attribute 'ceil'


tensorflow:2.0.0
python:3.6.8
rnnk:1.12.0
求助大佬帮忙解决一下

回复

使用道具 举报

troy

版主

积分
2370
发表于 2019-10-25 08:47:35 | 显示全部楼层
pip3 install tensorflow==1.14.0安装低版本的TensorFlow就可以,目前rknn还不兼容TensorFlow2.0
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

产品中心 购买渠道 开源社区 Wiki教程 资料下载 关于Toybrick


快速回复 返回顶部 返回列表